青青子衿, 悠悠我心, 但为君故, 沉吟至今
« 城市吧新增加了十三个城市的实景地图重新设置访问Flickr图片 »

IE7的未验证的发行者MSXML 5.0安全问题

  有个使用IE7的读者告诉我,当使用IE7浏览我博客的内容的时候,会在顶部提示这样的信息:“此网站需要运行以下加载项:"Microsoft Corporation(未验证的发行者)"中的"MSXML 5.0".如果您信任该网站和该加载项并允许运行该加载项,请单击这里……”

  我曾经安装过IE7,感觉很不习惯,于是又换回IE6了,而我使用IE6和FireFox访问我的博客却从来没有这种现象,为什么使用IE7会提示这种信息呢?

  经过我对博客代码的分析,我觉得可能是因为我安装的一个“博客投票插件”的原因,这个插件的JavaScript代码中,为了实现AJax效果,使用了XmlHttpRequest对象,因此,可能是因为IE7中本地执行XmlHttpRequest对象被MSXML5.0给拒绝执行了,因此本地安装了MSXML 5.0 (Office 2003之后的版本)后,就会在IE7中弹出“未验证的MSXML 5.0”。

  这个不知道算不算IE7或者MSXML的BUG,反正这个错误信息我目前无法在我的电脑上重现,出现这种情况的用户,请尝试安装一下最新版本的MSXML,或者修改一下IE7的安全设置就不会再出现类似问题了。



  除非注明,月光博客文章均为原创,转载请以链接形式标明本文地址

  本文地址:http://www.williamlong.info/archives/1206.html
  • 文章排行:
  • 1.星梦逍遥
  • 嗯 用IE7有时候的确会有说加载什么什么的
  • 2008/1/15 6:32:05   支持(14)反对(7) 回复
  • 4.浪
  • 最无耻的浏览器就是firefox
    你用firefox搜索框每搜索一次就送点钱给mozilla,真tmd流氓到家了!!!
  • 2008/1/13 23:52:32   支持(9)反对(5) 回复
  • 5.webmanage
  • 是有这个问题,我现在就用IE7重现了,不过充许过一次就不会再出现了
  • 2008/3/29 11:55:04   支持(8)反对(4) 回复
  • 7.86
  • 还是firefox好用啊,尤其是在linux系统下,微软实在是树大招风
  • 2008/1/13 21:01:29   支持(10)反对(8) 回复
  • 8.Heyi
  • 明天回家,春节回来再见了!See you around after Spring Festival, Williamlong! Happy blogging!
  • 2008/1/13 19:26:19   支持(18)反对(17) 回复
  • 10.北极冰仔
  • 的确是由于 XHR 引起的,月光说的没错。
  • 2008/1/13 21:56:02   支持(9)反对(8) 回复
  • 11.blogger
  • 月光也有落后的时候~~(暗笑中
  • 2008/1/14 13:28:52   支持(10)反对(9) 回复
  • 12.莫非
  • 我的也是这个问题呢..也不知道能不能安装那个插件..
  • 2008/8/26 17:55:34   支持(6)反对(5) 回复
  • 13.浪
  • Firefox强加了百度推广代码和google
    Adsense里的搜索代码,白给我都不用。

    要用就用IE或Opera,
    http://vki.net.ru/opera
    上面是中文优化版
  • 2008/1/13 23:38:05   支持(6)反对(6) 回复
  • 16.yksoft1
  • real插件问题很简单,
    因为最近流行Real网马
    以前06014的网马一样会出提示
    当然在safari下一切皆空~
  • 2008/1/16 12:40:41   支持(10)反对(10) 回复
  • 18.如夢
  • 不是IE7不好用,而是比IE7好用的瀏覽器多的是。
  • 2008/1/13 21:32:01   支持(8)反对(9) 回复
  • 19.frtime
  • 看看是什么??????????????
  • 2008/1/13 21:44:31   支持(9)反对(10) 回复
  • 20.vince
  • IE7很好用啊,月光应该试着去接受新事物了,呵呵。我的IE7以前也经常遇到加载项方面的问题,不过现在一直都没有出现了,应该是IE补丁起作用了。
  • 2008/1/14 12:01:43   支持(7)反对(8) 回复
  • 22.杀鸡敬猴
  • 我也相当不喜欢用IE7,目前用的世界之窗很好用,小巧玲珑。
  • 2008/1/13 20:06:17   支持(10)反对(12) 回复
  • 24.飘易博客
  • IE7的确垃圾,装了google工具栏后,那个打开网页的速度简直接受不了。
    装了3次,卸了3次。
  • 2008/1/15 9:17:45   支持(9)反对(11) 回复
  • 26.Kit
  • N多网站都会出现这个东西 允许一次就可以了 cctv 太平洋论坛等等
    现在最多的是real的控件 有些网站根本没有使用real都出现这东西
    应该这个插件有漏洞
  • 2008/1/13 20:27:43   支持(5)反对(9) 回复
  • 27.Henry
  • IE7是我用过最好最稳定的浏览器,会有这样的遥传其实是自身管理不到位,更新补丁没打全而已。我浏览月光一切正常。而且没有见过IE7引发的任何安全隐患,希望没有好好测试,只用了一两个的人不要枉加评论IE7!
  • 2008/1/14 10:26:38   支持(7)反对(12) 回复
  • 28.blue
  • 我觉得IE7.0很好用,比6.0强多了,很多功能对于操作和提高阅读效率与感受都非常好,其实大家都是不习惯的原因导致的(同样的原因还有
    Vista),用几天习惯了再用6.0时就会觉得:疑,怎么在7.0里这么简单的操作还要这么麻烦?
  • 2008/1/13 20:42:59   支持(13)反对(19) 回复
  • 31.DylenNewman
  • IE6.0不是号称IE史上最烂版本吗???
    IE7好多了。。。
    不过现在用傲游比较多
  • 2008/1/13 21:04:02   支持(6)反对(15) 回复

发表评论:

 请勿发送垃圾信息、广告、推广信息或链接,这样的信息将会被直接删除。

订阅博客

  • 订阅我的博客:订阅我的博客
  • 关注新浪微博:关注新浪微博
  • 关注腾讯微博:关注腾讯微博
  • 关注认证空间:关注QQ空间
  • 通过电子邮件订阅
  • 通过QQ邮件订阅

站内搜索

热文排行


月度排行

本站采用创作共用版权协议, 要求署名、非商业用途和相同方式共享. 转载本站内容必须也遵循“署名-非商业用途-相同方式共享”的创作共用协议.
This site is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 License.