月光博客 » 网站建设 » IE7的未验证的发行者MSXML 5.0安全问题

IE7的未验证的发行者MSXML 5.0安全问题

  有个使用IE7的读者告诉我,当使用IE7浏览我博客的内容的时候,会在顶部提示这样的信息:“此网站需要运行以下加载项:"Microsoft Corporation(未验证的发行者)"中的"MSXML 5.0".如果您信任该网站和该加载项并允许运行该加载项,请单击这里……”

  我曾经安装过IE7,感觉很不习惯,于是又换回IE6了,而我使用IE6和Firefox访问我的博客却从来没有这种现象,为什么使用IE7会提示这种信息呢?

  经过我对博客代码的分析,我觉得可能是因为我安装的一个“博客投票插件”的原因,这个插件的JavaScript代码中,为了实现AJax效果,使用了XmlHttpRequest对象,因此,可能是因为IE7中本地执行XmlHttpRequest对象被MSXML5.0给拒绝执行了,因此本地安装了MSXML 5.0 (Office 2003之后的版本)后,就会在IE7中弹出“未验证的MSXML 5.0”。

  这个不知道算不算IE7或者MSXML的BUG,反正这个错误信息我目前无法在我的电脑上重现,出现这种情况的用户,请尝试安装一下最新版本的MSXML,或者修改一下IE7的安全设置就不会再出现类似问题了。

IE7的未验证的发行者MSXML 5.0安全问题

顶一下 ▲()   踩一下 ▼()

相关文章

  1. 1
    星梦逍遥   说道:
    嗯 用IE7有时候的确会有说加载什么什么的
    支持(15反对(7回复
  1. 2
    ue   说道:
    ie7访问正常
    支持(10反对(3回复
  1. 3
    jayboke   说道:
    是啊。我的IE7也正常
    支持(13反对(7回复
  1. 4
      说道:
    最无耻的浏览器就是firefox
    你用firefox搜索框每搜索一次就送点钱给mozilla,真tmd流氓到家了!!!
    支持(10反对(5回复
  1. 5
    webmanage   说道:
    是有这个问题,我现在就用IE7重现了,不过充许过一次就不会再出现了
    支持(9反对(4回复
  1. 6
    奇迹   说道:
    有道理··········
    支持(11反对(7回复
  1. 7
    86   说道:
    还是firefox好用啊,尤其是在linux系统下,微软实在是树大招风
    支持(11反对(8回复
  1. 8
    Heyi   说道:
    明天回家,春节回来再见了!See you around after Spring Festival, Williamlong! Happy blogging!
    支持(19反对(17回复
  1. 9
    sunmm   说道:
    前排板凳,看月光舞蹈
    支持(18反对(16回复
  1. 10
    北极冰仔   说道:
    的确是由于 XHR 引起的,月光说的没错。
    支持(10反对(8回复

发表留言